0

I have a simple question. I am writing some code (c++) and that uses libraries licensed as Mit and Apache 2.0 (which I know are compatible). My question is can I use libraries that have a boost 1.0 license as well?

In other words can I do this:

#include some_lib_a.hpp // Mit licence
#include some_lib_b.hpp // boost licence
#include some_lib_c.hpp // Apache 2.0 licence

The code I am writing contains some fully or partial derivative works licensed as Mit or Apache 2.0. The rest will probably be licensed as Mit or Apache 2.0, with a few portions intentionally kept closed source.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.